Kiosk Check-In Not Working

Incident Report for HotDoc

Resolved

We can confirm that this issue has now been resolved and functionality for Kiosk Check-in should be back to normal.
Posted May 06, 2026 - 13:26 AEST

Update

We are continuing to investigate this issue.
Posted May 06, 2026 - 13:26 AEST

Investigating

We are currently aware of a issue affecting all clinics using both Kiosk and Best Practice who are currently experiencing an issue where kiosk check-in fails, leaving patients stuck on the "Please go see reception" screen.

Engineering has confirmed this is related to the May BP Update.

Our team is working to resolve these issues as a priority and will provide further updates as they become available.
Posted May 06, 2026 - 11:49 AEST
This incident affected: hotdoc.com.au and Practices (Kiosk).