Processing Delay for Specialist Bookings
Incident Report for HotDoc
Resolved
Thank you for your patience while we resolve this issue. We have been able to work with Genie and can now confirm that processing delay has been resolved.
Posted May 16, 2024 - 09:06 AEST
Identified
We have identified a processing delay for Specialist bookings. Currently we are seeing a delay of up to 3 hours. We are working with Genie Solutions to investigate this issue. We will update with further information soon.
Posted May 15, 2024 - 15:32 AEST
This incident affected: hotdoc.com.au.